Download our apps

Download our apps

Forex Trading

iPhone, iPad, and iPod Touch
(running iOS 5.1+)

Download


Android
(running Android 2.1+)

Download


BlackBerry
(compatible with 9000, 9650, and 9700 series devices running OS 4.6 to 6.0)

Download


Other Devices

Our HTML5 fxTrade application should be supported by most modern mobile devices with internet connectivity.

Go to fxMobile


Currency Converter

iPhone, iPad, and iPod Touch
(running iOS 5.1+)

Download


Android
(running Android 2.1+)

Download


BlackBerry
(running 4.21 OS+ – does not support Storm devices or Torch touch interfaces)

Download


Playbook
(running 1.0+)

Download